When I write code, I don't care how the function is named. But when it's done, I want a good and short name.
Often my methods are just called "magic" since I don't care yet. After it's complete, I update the name that explains what the code does. This results